Công ty cổ phần công nghệ Nghĩa Hưng

Cấu hình port trunk, intervlan routing, phân tích gói tin vlan

Hướng dẫn cách cấu hình port Trunk cho switch, intervlan routing trên router định tuyến giữa các vlan, phân tích gói tin vlan

DS máy chủ mới nhập kho giá rẻ. Anh em tham khảo ủng hộ nha.

Máy chủ DELL R640: http://nghiahung.vn/dell-poweredge-r640-b2477448.html

Máy chủ DELL R740: http://nghiahung.vn/dell-poweredge-r740-b2477449.html

Linh kiện máy chủ loại nào cũng có liên hệ: 0976040346 Mr Tâm ( tư vấn mua hàng, kỹ thuật, báo giá ...) Phụ vụ anh em 24/24.

---------------------------------------

Hướng dẫn cách cấu hình port Trunk cho switch, intervlan routing trên router định tuyến giữa các vlan, phân tích gói tin vlan


Yêu cầu:

- PC1, PC2 thuộc Vlan 10 ping thông PC3,PC4 thuộc  Vlan20 ( PC1 và PC2 khi chưa cấu hình router đã ping thông, PC3 và PC4 ping thông)
- PC1 và PC2 thuộc Vlan10 nằm trong cùng 1 dải mạng 192.168.1.0/24
- PC3 và PC4 thuộc Vlan20 nằm trong cùng 1 dải mạng 10.0.0.0/24
- Switch 1 nối với switch 2 bằng 1 link trunk.
- Switch 1 nối với Router bằng link Trunk, trên router cấu hình intervlan routing định tuyến 2 lớp mạng khác nhau

Lưu ý: Khi cấu hình intervlan routing định tuyến Giữa các Vlan, các PC cùng vlan phải cùng 1 dải địa chỉ IP, và có default gateway trỏ đến địa chỉ Sub interface trên router.

mô hình intervlan routing
Định nghĩa link trunk: Là link kết nối giữa các thiết bị switch với switch, switch với router.
Đặc điểm: Link trunk cho phép tất cả gói tin thuộc nhiều vlan khác nhau đi qua link này, gói tin đi từ switch này đến switch khác hoặc router sẽ được tag trường IDvlan chỉ định, gói tin đi qua link access không tag vlan ID

Các bước cấu hình:

1.Đặt địa chỉ IP cho 4 PC

PC1 và PC2 IP address lần lượt là 192.168.1.2/192.168.1.3 default gateway 192.168.1.1
PC3 và PC4 IP address lần lượt là 10.0.0.2/10.0.0.3 default gatewat 10.0.0.1

2.Cấu hình switch

Cấu hình switch1:
Tạo vlan 10, 20 cho switch 1
Switch1(config)#vlan 10
Switch1(config-vlan)#name kythuat

Switch1(config)#vlan 20
Switch1(config-vlan)#name ketoan

Tạo port access vlan 10 cổng f0/3, vlan 20 cổng f0/2
Switch1(config)#interface f0/2
Switch1(config-if)#switchport access 20

Switch1(config)#interface f0/3
Switch1(config-if)#switchport access 10

Tạo port trunk trên cổng f0/1 và f0/4 cho phép gói tin vlan 10 và vlan  20 đi qua link  từ switch 1 đến switch 2 và switch 1 đến router
Switch1(config)#interface f0/1
Switch1(config-if)#switchport mode trunk

Switch1(config)#interface f0/4
Switch1(config-if)#switchport mode trunk

Cấu hình Switch 2:
Tạo vlan 10 và vlan 20 cho switch 2
Switch2(config)#vlan 10
Switch2(config-vlan)#name kythuat

Switch2(config)#vlan 20
Switch2(config-vlan)#name ketoan

Tạo port access vlan 10 cổng f0/2, vlan 20 cổng f0/3
Switch2(config)#interface f0/2
Switch2(config-if)#switchport access 10

Switch2(config)#interface f0/3
Switch2(config-if)#switchport access 20

Tạo port trunk trên cổng f0/4 của switch 2 cho phép gói tin thuộc vlan 10 và vlan 20 đi qua link này.
Switch2(config)#interface f0/4
Switch2(config-if)#switchport mode trunk

3.Cấu hình Router
Router(config)# interface F0/0.1 ( tạo sub interface f0/0.1 )
Router(config-subif)# encapsulation dot1Q 10 ( cổng f0/0.1 làm default gateway cho vlan 10 )

Router(config)# interface F0/0.2 ( tạo sub interface f0/0.2 )
Router(config-subif)# encapsulation dot1Q 20 ( cổng f0/0.2  làm default gateway cho vlan 20 )
Định tuyến 2 vlan thì tạo 2 sub interface dot1Q 10 và 20, làm tương tự nếu có thêm nhiều vlan khác nữa

Vậy là cấu hình vlan, port trunk và định tuyến trên router đã xong. Giờ bạn tiến hành test câu lệnh ping giữa các PC nằm ở Vlan khác nhau.

Ping từ PC1 ip address 192.168.1.2 đến PC4 địa chỉ 10.0.0.3 thành công.
test vlan ping pc1 đến pc4

Ping từ PC1 ip address 192.168.1.2 đến PC3 địa chỉ 10.0.0.2 thành công

test vlan ping pc1 đến pc3
 

4.Phân tích đường đi gói tin:
Chiều đi: PC1 > Switch1 tag vlanID10 > Router F0/0.1 > Router F0/0.2 tag vlanID20 > Switch1 > PC4
Chiều về: PC4 > Switch1 tag vlanID20 > Router F0/0.2 > Router F0/0.1 tag vlanID10 > Switch1 > PC1

Tương tự các PC nào khác vlan và thuộc các dải mạng khác nhau sẽ phải đi qua router để routing đồng thời router sẽ tag VlanID tương ứng với địa chỉ mạng đích để switch có thể chuyển gói tin đến địa chỉ PC thuộc vlan đó.

 

Bạn đang xem: Cấu hình port trunk, intervlan routing, phân tích gói tin vlan
Bài sau
Đăng nhập
Đăng ký
Hotline: 024.3552.5840
x
Công ty cổ phần công nghệ Nghĩa Hưng